**!PLEASE ACTION NOW!** Please update your App Store Connect Agreements.

Incident Report for VidApp

Update

If you have not done so already, please log into App Store Connect and agree to any outstanding agreements.
These agreements are regularly updated by Apple and require the consent of the account holder.

When you can, please set up a filter for the alert on your email service so that it is marked important & actioned when Apple sends the agreement update notice to the Account Holder's inbox.

Unaccepted agreements block app updates, bug fixes and payments on your app and platform.
Posted Nov 05, 2025 - 23:30 UTC

Monitoring

If you have not done so already, please log into App Store Connect and agree to any outstanding agreements.
These agreements are regularly updated by Apple and require the consent of the account holder.

When you can, please set up a filter for the alert on your email service so that it is marked important & actioned when Apple sends the agreement update notice to the Account Holder's inbox.

Unaccepted agreements block app updates, bug fixes and payments on your app and platform.
Posted Oct 30, 2025 - 03:48 UTC
This incident affects: Support Center.